Google Play Store vous empêchera bientôt de télécharger des applications obsolètes :

Apple a purgé à plusieurs reprises les applications de l’App Store qui ne sont pas conçues pour les derniers modèles d’iPhone ou les nouvelles versions d’iOS, ce qui est généralement bénéfique pour l’expérience logicielle globale, mais a rendu la préservation des anciennes applications et jeux beaucoup plus difficile. Google a hésité à faire les mêmes démarches avec le Google Play Store, mais cela va bientôt changer.

Google a annoncé dans un article de blog, “À partir du 1er novembre 2022, les applications existantes qui ne ciblent pas un niveau d’API dans les deux ans suivant la dernière version majeure d’Android ne seront pas disponibles pour la découverte ou l’installation pour les nouveaux utilisateurs avec des appareils exécutant des versions du système d’exploitation Android supérieures à l’API cible des applications. niveau. Au fur et à mesure que de nouvelles versions du système d’exploitation Android seront lancées à l’avenir, la fenêtre d’exigences s’ajustera en conséquence. ”

XDA-Developers VIDÉO DU JOUR :
Exigences de niveau d'API cible pour les applications existantes, à compter du 1er novembre :

Chronologie des nouvelles exigences de l’API cible (Source : Google)

Les applications et les jeux Android sont créés avec deux versions différentes d’Android : le niveau d’API minimum et le niveau d’API “cible”. La première est la version la plus ancienne d’Android avec laquelle une application est destinée à fonctionner, tandis que la seconde est la version Android la plus récente pour laquelle l’application est conçue. Les développeurs sont censés maintenir le niveau d’API cible proche de la version Android la plus récente, ce qui permet à une application d’utiliser les dernières API et fonctionnalités de développement. Cependant, les nouveaux niveaux d’API introduisent également généralement plus de restrictions sur les autorisations, c’est pourquoi certaines applications restent sur les anciens niveaux d’API aussi longtemps que possible. Snapchat est peut-être l’exemple le plus célèbre ici, qui est resté fidèle au niveau d’API 22 (Android 5.1) pendant des années pour éviter le modèle d’autorisations d’exécution introduit dans Android 6.0.

Google exige déjà de nouvelles applications et des mises à jour des applications existantes pour cibler une version récente d’Android, qui est actuellement définie sur Android 11 (niveau API 30) et sera augmentée à Android 12 (niveau API 31) en août 2022. Cependant, cette exigence ne s’applique aux applications encore en cours de développement – les applications et jeux anciens et abandonnés ont été laissés seuls, tant qu’ils sont toujours conformes aux autres politiques du Play Store.

Cette décision améliorera probablement la confidentialité et la sécurité, car les applications devront suivre l’évolution des autorisations et des changements de sécurité d’Android si elles veulent rester accessibles sur le Play Store. Cependant, l’accès à de nombreuses applications plus anciennes deviendra plus difficile (voire impossible), en particulier après la première purge du 1er novembre. Heureusement, il est plus facile de sauvegarder et de conserver les anciennes applications et jeux sur Android que sur iOS.


La source: Développeurs Android :

Leave a Comment